yarn 安裝套件出現錯誤 Integrity check failed for “graceful-fs” (computed integrity doesn’t match our records…

記錄一下在新電腦clone專案,遇到的安裝套件問題。

原本新專案都要先安裝node套件,會下這個指令:

$ yarn

但是今天在別的電腦下這指令,出現以下錯誤:

Integrity check failed for "graceful-fs" (computed integrity doesn't match our records

他的錯誤有建議你可以先清除快取:

$ yarn cache clean

但清除後,仍然有同樣錯誤。

有些人說要先刪除yarn.lock,但這樣我可能會要等他重載跑很久。

所以在網路上找到可以使用指令只尋找有問題的套件進行更新:

$ yarn --update-checksums

這樣跑完,就可以直接啟動專案了。

學習程式原來可以這麼簡單:六角學院線上課程

初學者如何成為vue前端工程師:查看課程內容

---------------------------

| 軟體開發 | 網站建置 | 網頁系統 | 資料庫網站 |

| 客製化網站 (報名系統、投票系統、掛號系統...) |

| 前後端技術合作 |

歡迎與我們聯繫:jessica@penueling.com

加入Line立即聊聊:@539mjyid

0
0 回復

發表評論

Want to join the discussion?
Feel free to contribute!

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。